Use Deprecated Encryption Algorithms

Check 'Use deprecated encryption algorithms to be compatible with the previous version' to support RSA 1024 for encryption and disable the related settings of RMS Setting in 'Preferences' menu.
If you have no option, there is the enhanced AD RMS cryptographic implementation. It supports RSA 2048 for encryption.

Only operating systems in the following list can support 'Enhanced AD RMS cryptographic implementation'.

AD RMS servers must be running Windows Server® 2008 R2 with Service Pack 1 (SP1)

AD RMS client computers running one of the following operating systems

Windows® 8

Windows® 7 with Service Pack 1 (SP1)

Windows Vista® with Service Pack 2 (SP2)

Windows Server® 2008 with Service Pack 2 (SP2)

Windows Server® 2008 R2 with Service Pack 1 (SP1)

Supported on: Microsoft Windows XP SP2 or later
Registry HiveHKEY_LOCAL_MACHINE or HKEY_CURRENT_USER
Registry PathSoftware\Policies\Foxit\PhantomPDF\RMS\Preferences
Value NameDeprecatedEncryption
Value TypeREG_DWORD
Enabled Value1
Disabled Value0

foxit phantompdf 7.3.admx

Administrative Templates (Computers)

Administrative Templates (Users)